Unable to sign in or log in to PitneyShip, PitneyShip Pro, PitneyTrack Asset, PitneyTrack Inbound, PitneyAnalytics, the Locker Management Module, ShipAccel, SendPro Tablet, or Your Account

There are several things that may cause issues when signing in.

Products affected: PitneyShip®, PitneyShip® Pro, PitneyShip® Enterprise, PitneyTrack® Asset, PitneyTrack® Inbound, PitneyAnalytics®, Locker Management Module, ShipAccel, SendPro® Tablet, Your Account

Issue

You cannot sign in to your account.

Cause

There are several things that may cause issues when signing in.

Resolution

Solution 1: Verify your username and password

Username (Email): Ensure you're using the correct email address associated with your PitneyShip account.

If your email address has changed, and you do not have access to your old email. Register for Your Account with your new email.

Password: Double-check for typos, especially if you're using a password manager. If you've forgotten your password, use the "Forgot your password?" link on the PitneyShip login page to reset it.

Solution 2: Check your browser and network

Clear browser cache and cookies: This can resolve issues caused by outdated information or conflicting data in your browser.

Verify internet connection: Make sure you have a stable internet connection, as login problems can sometimes be due to network issues.

Check for outdated links or bookmarks: If you're using an outdated bookmark or link, it may point to a broken login page.

If you've made too many incorrect login attempts, your account may be locked. You'll need to reset your password.

Solution 3: If emails are not being received

If you did not get the password reset email:

  • Try selecting Send Reset Password email again.
  • Check your Junk/Spam folder.
  • Check with your IT department to make sure that the address [email protected] is not being blocked.

If you did not get the Multi-Factor Authentication (MFA) code email, see:

Solution 4: Try again later

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UPDATED: May 14, 2025