Missing email address error when shipping a package with the UPS API in SendPro Enterprise
Learn how to resolve the issue when an error is received for a missing email address when shipping a package with the UPS API in SendPro Enterprise
Products affected: SendPro® Enterprise
Issue
When attempting to ship a package with theUPS API an error is returned for a missing email address.
Cause
The sender or recipient information is missing for shipments sent through the UPS API. This causes the API to return an error, which stops the system from creating a shipping label or processing the shipment.
Resolution
Add a valid email address for both the sender (ship from) and recipient (ship to).
UPDATED: October 23, 2025