"Some required ports are unavailable" and "Some checks could not be completed" DeviceHub Compatibility Checker messages in PitneyShip, PitneyShip Pro, or PitneyShip Enterprise
Products affected: PitneyShip®, PitneyShip® Pro, PitneyShip® Enterprise
Issue
When using the DeviceHub Compatibility Checker, you receive a "Some required ports are unavailable" or "Some checks could not be completed" message.
Cause
If you received the "Some required ports are unavailable" message, it means that ports 443 or 8091 are unavailable. See Solution 1 to resolve this issue.
If you received the "Some checks could not be completed" message, it means that ports are unavailable and URLs are not whitelisted. See both Solution 1 and Solution 2 to resolve this issue.
Resolution
Solution 1: Ensure that port 443 or 8091 is free
These steps may need to be completed by your IT department or network administrator.
- From the system tray (small icons near the clock), right-click on the DH icon and choose Exit to close DeviceHub.
- Open a DOS command window (cmd) and run this command: netstat -ano -p tcp
- Search for 127.0.0.1:443 or 0.0.0.0:443 and note the PID number.
Steps in Task Manager
- Open the Task Manager and select the Details tab.
- Search for the PID number. Stop the program, then try again to start DeviceHub. Some programs maybe running via a Windows Service and will require the stopping of the service, so the program does not restart.
- Launch DeviceHub.
- In PitneyShip, PitneyShip Pro, or PitneyShip Enterprise go to My Devices and click to Activate. You may need to refresh the page.
If you are still receiving this error, follow these steps for additional troubleshooting:
- Find the application that is using port 443 or 8091.
- Shut down the application using port 443 or 8091.
- Start DeviceHub.
- Activate DeviceHub.
- Shut down DeviceHub.
- Restart the original conflicting application.
- Start DeviceHub.
If you received the "Some checks could not be completed" message, continue to Solution 2.
Solution 2: Whitelist URLs
DeviceHub requires certain URLs to be whitelisted. For a complete list of URLs, see:
The features and options you see may vary depending upon your role and subscription. If you have any questions regarding your permissions, please contact your administrator.
UPDATED: December 08, 2025