A white or blank screen on create shipping labels on the SendPro C Lite, SendPro C, SendPro+, SendPro C Auto

The screen is blank or white when entering Create Shipping labels.

Products affected: SendPro® C Lite, SendPro® C, SendPro®+, SendPro® C Auto  (2H00, 8H00, 9H00)

Issue

The screen is blank or white when creating Shipping labels.

Cause

The device is not connecting to the Pitney Bowes Data Center

Resolution

Solution 1: Restart your device

You may be able to clear the error by simply restarting your device. Here are the steps to follow for a safe restart:

  1. Unplug the power cord.
  2. Wait for the display to turn off.
  3. Wait 30 seconds.
  4. Plug the power cord directly back into a wall outlet.
  5. Quickly tap the power button.

Solution 2: Check your connection

If the connection still does not work, check the connection icon on your toolbar.

Wired (Ethernet) connection

If you have a network cable that runs from the back of your device to a wall jack, switch, or router, your device connects via a wired (Ethernet) connection. When your internet connection is down, the Ethernet image has a white line through it.
spc-lan-not-connected

Please see Wired network connection issues for more information.

Wireless connections

If there is no network cable, your device connects via a wireless (Wi-Fi) connection. When your internet connection is down, the Wi-Fi image has a white line through it.
spc-wifi-not-connected-2

Please see Wireless (Wi-Fi) connection issues for more information.

Solution 3: Check for network security issues

Your network security may be blocking ports or addresses that the device requires to function properly. Contact your IT department for assistance if needed.

UPDATED: December 15, 2025