Rate and Print buttons do not work in Mailcenter App in SendPro Enterprise

If the Rate and Print buttons do not work in Mailcenter App, there may be an issue with the system configuration. Contact us for assistance.

Products affected: SendPro® Enterprise

Issue

When selecting the Rate or Print buttons in the Mailcenter App, there is no response from the app, even though all required fields are filled in.

Cause

There may be an issue with the system configuration.

Resolution

This issue must be resolved by a Pitney Bowes representative.

If you need further assistance, please chat with us.

UPDATED: January 28, 2026