Recipient is not receiving SMS notifications in PitneyTrack Inbound, PitneyTrack Enterprise or the Locker Management Module

If the recipient is not receiving tracking or delivery SMS notifications from the system, the feature may not be enabled, the recipient's phone number may be set up incorrectly, or the SMS phone number may be being blocked.

Products affected: PitneyTrack® Inbound, PitneyTrack® Enterprise, Locker Management Module.

Issue

The recipient is not receiving SMS notifications from the system.

Cause

There are several things that may cause the SMS notifications to not be received.

Resolution

Solution 1: Enable SMS notifications

Make sure that you have SMS notifications enabled. See Creating Custom Notifications.

Solution 2: Validate the phone number for the contact

  1. Go to Settings > Address Book.
  2. Locate the contact that is not receiving the SMS notifications.
  3. Make sure that the correct phone number is saved for that contact. Valid phone number formats are:
    • 9 Digits - 2035551234.
    • 10 Digits - 12035551234.
    • 10 Digits + Plus Character - +12037671196.

Solution 3: Enable the SMS Notification feature for the contact

  1. Go to Settings > Address Book.
  2. Locate the contact that is not receiving the SMS notifications.
  3. Check the Send SMS Notification checkbox to enable SMS Notifications for the contact.

Solution 4: Unblock the SMS Phone Number

Steps to check phone numbers blocked depends on the phone manufacturer and mobile application. See the steps provided by the manufacturer or mobile app developer. Contact their support for assistance.

The system generates SMS notification from this phone number 651-369-8366.

The recipient should unblock this number in order to receive the SMS notifications from the system.

The features and options you see may vary depending upon your role and subscription. If you have any questions regarding your permissions, please contact your administrator.

UPDATED: April 22, 2026