"Update your USPS Shipping Account Details" message in PitneyShip, PitneyShip Pro, or PitneyShip Enterprise, or on the SendPro C series, Connect+ series, SendPro P, or SendPro MailCenter

If you see the message "Update your USPS Shipping Account Details", the address that is saved in your profile does not meet the USPS requirements or no longer matches your USPS shipper ID.

Products affected: PitneyShip®, PitneyShip® Pro, PitneyShip® Enterprise, SendPro® C series, Connect+® series, SendPro® P, SendPro® MailCenter

Issue

When creating a USPS shipping label or signing in, you see an "Update your USPS Shipping Account Details" window.

Cause

The address that is saved in your profile does not meet the updated USPS requirements or no longer matches your USPS shipper ID.

Resolution

When prompted, update your address as indicated. The window will show which fields need to be updated with red text below the fields.

If you see the "Update your USPS Shipping Account Details" message on a meter, you will need to sign in to your PitneyShip, PitneyShip Pro, or PitneyShip Enterprise account on a computer. When you sign in, you will be prompted to update the address.
Update message on a meter

If you are not a system administrator and see this message, contact your admin to update the address.
Contact your admin message

The features and options you see may vary depending upon your role and subscription. If you have any questions regarding your permissions, please contact your administrator.

UPDATED: May 19, 2026