"Device hub connection timeout" message when printing in PitneyShip

If you see the message "Device hub connection timeout" when printing in PitneyShip, try moving the printer to a different USB port.

Issue

"Device hub connection timeout" message when printing in PitneyShip

Cause

There is a USB issue with the connected printer.

Resolution

Move the printer to a different USB port and try again.

If you need further assistance, please contact us.

UPDATED: June 01, 2022

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