"DeviceHub is already running" message when installing or updating DeviceHub in PitneyShip or PitneyShip Pro
If the message "DeviceHub is already running" appears when installing or updating DeviceHub, either DeviceHub is stuck running in the background, or the previously installed version is corrupt.
Products affected: PitneyShip™, PitneyShip™ Pro
Issue
The message “DeviceHub is already running” appears when installing or updating DeviceHub for PitneyShip or PitneyShip Pro.
Cause
Either DeviceHub is stuck running in the background or the previously installed version is corrupt.
Resolution
- Press Alt+Ctrl+Delete on the keyboard.
- Select Task Manager.
- Select the Details tab.
- Right-click on DeviceHub and choose End Task.
- Select End Process.
- If DeviceHub is listed more than once, repeat steps 4 and 5.
- Uninstall DeviceHub. See Uninstalling DeviceHub in PitneyShip or PitneyShip Pro.
- Install a new copy of DeviceHub. See Installing DeviceHub for PitneyShip and PitneyShip Cube.
If you need further assistance, please contact us.
UPDATED: December 14, 2022