"DeviceHub is already running" message when installing or updating DeviceHub in PitneyShip, PitneyShip Pro, or PitneyShip Enterprise

If the message "DeviceHub is already running" appears when installing or updating DeviceHub, either DeviceHub is stuck running in the background, or the previously installed version is corrupt.
Products affected: PitneyShip®, PitneyShip® Pro, PitneyShip® Enterprise

Issue

The message “DeviceHub is already running” appears when installing or updating DeviceHub.

Cause

Either DeviceHub is stuck running in the background or the previously installed version is corrupt.

Resolution

  1. Press Alt+Ctrl+Delete on the keyboard.
  2. Select Task Manager.
  3. Select the Details tab.
  4. Right-click on DeviceHub and choose End Task.
  5. Select End Process.
  6. If DeviceHub is listed more than once, repeat steps 4 and 5.
  7. Uninstall DeviceHub. See:
  8. Install a new copy of DeviceHub. See:

UPDATED: December 21, 2023