"Something went wrong. Please try again later. 2498 Recipient/Third party account validation failed." message in PitneyShip Pro

The message "Something went wrong. Please try again later. 2498 Recipient/Third party account validation failed." means that there is an issue with the third party or recipient account being billed.
Products affected: PitneyShip™ Pro

Issue

When trying to use Third Party or Recipient billing with a FedEx or UPS shipment, the message "Something went wrong. Please try again later. 2498 Recipient/Third party account validation failed." appears.

Cause

There is an issue with the Third Party or Recipient FedEx or UPS account that is being billed. It may be inactive, suspended, or the carrier account may not be a United States carrier account.

Resolution

Contact the owner of the UPS or FedEx account that is being billed. The account owner needs to verify that the account is in good standing and that it is based in and billed in the United States.

UPDATED: 18 October 2023