"Looks like your FedEx account details have changed" message in PitneyShip, PitneyShip Pro, PitneyShip Enterprise, or ShipAccel

The message "Looks like your FedEx account details have changed. Update it by clicking the edit icon, then try authenticating your account again." means that the address, name, company name, email, or phone number of your FedEx account in does not match the information that FedEx has on file for the account.

Products affected: PitneyShip®, PitneyShip® Pro, PitneyShip® Enterprise, ShipAccel

Issue

When trying to authenticate your FedEx account, the message "Looks like your FedEx account details have changed. Update it by clicking the edit icon, then try authenticating your account again." appears.

Cause

The address, name, company name, email, or phone number of your FedEx account in PitneyShip, PitneyShip Pro, PitneyShip Enterprise, or ShipAccel does not match the information that FedEx has on file for the account.

Resolution

  1. Click the edit icon next to the FedEx account.
    Edit icon
  2. Update the information to match the FedEx account.
  3. Try the authentication process again.

UPDATED: June 11, 2025