"Certificate-based activation is required for DeviceHub" message in PitneyShip, PitneyShip Pro, or PitneyShip Enterprise

If you see the message "Certificate-based activation is required for DeviceHub", that means your system requires DeviceHub to be activated manually.

Products affected: PitneyShip®, PitneyShip® Pro, PitneyShip® Enterprise

Issue

The message "Certificate-based activation is required for DeviceHub" appears on the My Devices page.
dh-certif-activation-banner

Cause

Your system has a setting requiring DeviceHub to be activated manually.

Resolution

Activate DeviceHub using these steps:

  1. Right-click on the DH DeviceHub icon in the Windows system tray (small icons near the clock) or Mac OS menu bar and select About.
  2. Select the copy icon next to the DeviceHub Serial Number.
    Copy icon for DeviceHub serial number
  3. In PitneyShip, PitneyShip Pro, or PitneyShip Enterprise, go to Settings > My Devices.
  4. Select Activate DeviceHub.
  5. In the Enter DeviceHub Serial Number window, click in the Serial Number field and paste the serial number you copied.
    Paste the serial number into the Serial Number field
  6. Select Continue.
  7. When the You're almost done message appears, click Done.
    You're almost done window when activating DeviceHub
  8. Right-click on the DeviceHub icon in the Windows system tray (small icons near the clock) or Mac OS menu bar and select Sync.
    Select Sync from the DH icon menu
  9. When you see the message "DeviceHub registered and activated!", click OK.
  10. You should now see the printers and scales that are connected to your computer listed on the My Devices screen. If you do not, click the Refresh button. If there are other shared DeviceHubs on your network, you may see them as well.

The features and options you see may vary depending upon your role and subscription. If you have any questions regarding your permissions, please contact your administrator.

UPDATED: December 18, 2025