Issue
Your meter asks for the root password and will not boot up.
Cause
The internal meter software has malfunctioned.
Resolution
A reboot may resolve the issue:
- Press and hold the blue power button until the display turns off.
- After the meter has been off for 10 seconds, press the power button to power back up.
If the issue is not resolved, please use the
Contact Us options below.
UPDATED: January 28, 2020