Screen is black or blank or the screen is in power saving mode on the Connect+ series and SendPro P

Print this support article
Products affected: Connect+® 500W, Connect+® 1000, Connect+® 2000, Connect+® 3000, SendPro® P1000, SendPro® P1500, SendPro® P2000, SendPro® P3000

Issue

Your meter's display is black, blank or in power saving mode.

Cause

The display may be off, disconnected, or malfunctioning.

Resolution

Solution 1

Ensure your meter is on:
  1. Check if the blue power light on the front of your meter is on.
Image showing power button
  1. If the light is off or blinking, press the power button to power up your meter.
  2. If the meter does not power up within a few minutes, check that the power cord is plugged into a functioning wall outlet.
Solution 2
  1. If you have the optional 15-inch display, there is a power button lower right corner along with a power LED. It also has an external power adapter instead of a power cable running through the tower.
  2. Your meter's display can show No Signal if the display is powered on, but the meter is off or the VGA cable is loose/disconnected.
  3. Sometimes the vibration from tapping the screen will cause the cables to loosen on the display. Check that all of the connections on the back of the display are tight and secure:
  • There is a 15-pin VGA that plugs into the left side of the meter.
  • There is a USB cable that connects to into the left side of the meter.
  • There is a power cable that runs into the display mounting tower.
If you need further assistance, please use the Contact Us options below.

Related articles

UPDATED: October 22, 2021