Resolve "PSD Key Lockout" on the Connect+ series and SendPro P series
Learn how to resolve a "PSD Key Lockout" message on the Connect+ 500W, Connect+ 1000, Connect+ 2000, Connect+ 3000, SendPro P1000, SendPro P1500, SendPro P2000 and SendPro P3000.
Products affected: Connect+® 500W, Connect+® 1000, Connect+® 2000, Connect+® 3000, SendPro® P1000, SendPro® P1500, SendPro® P2000, SendPro® P3000
Issue
The Connect+® / SendPro™ P Series displays the message PSD Key Lockout and will not run mail.
Cause
An internal component has failed.
Resolution
Reboot the system. Follow these steps to restart safely:
- Select the Gear from the lower right corner of the home screen.
- Select Shut Down from the menu.
- Select Shut Down on the pop-up.
- Wait for the screen to go black and for the blue light on the front to go out. This may take several minutes.
- Wait 10 more seconds.
- Press the Power button.
UPDATED: August 14, 2021
Contact Us
Live Chat
Available • Closes at 8pm ET
Sales team hours are 8am-6pm ET
Sales team hours are 8am-6pm ET
Live Chat
Live Chat is currently unavailable.
Chat is available Mon-Fri, 8am-8pm ET
Chat is available Mon-Fri, 8am-8pm ET
Create a case
Submit support requests
(Sign in required)