"USPS Failed to Rate" when rating USPS in SendPro Enterprise

Learn how to resolve the error "USPS Failed to Rate" when rating USPS in SendPro Enterprise.
Products affected: SendPro® Enterprise

Issue

When rating any USPS service with no special services selected, the error message "USPS Failed to Rate" is displayed.

The diagnostics logs will show an additional error of "Invalid URI: The hostname could not be parsed."

Cause

The USPS carrier is only intended to be used for Electronic Return Receipt (ERR) shipments. In order to rate, it requires special services "Certified" and "Electronic Return Receipt" to be selected.

Resolution

If you are trying to ship a regular, non-ERR shipment, select carrier "PB Shipping API - USPS".

Use the USPS carrier for ERR shipments only, with "Certified" and "Electronic Return Receipt" selected.

UPDATED: June 02, 2021