"Failure to print via CSD Print Service" message on the SendPro C Lite, SendPro C, SendPro+, SendPro C Auto

If you are seeing the message "Failure to print via CSD Print Service," use one of these solutions to resolve it.
Products affected: SendPro® C Lite, SendPro® C, SendPro®+, SendPro® C Auto  (2H00, 8H00, 9H00)

Issue

When running the Create Shipping Labels app, the message "Failure to print via CSD Print Service" appears.

Cause

  • Make sure you connect the label printer to the device.
  • The device has become disconnected from the tablet.

Resolution

Solution 1: Verify the label printer connections

  1. Make sure you connect the power cable to the label printer and the printer is powered on.  A green light on the printer indicates the power is on. 
  2. Make sure you connect the USB cable on the back of the printer to the back of the device. 

Solution 2: Reboot the device

  1. Unplug the power cord. The screen should turn off after 10 seconds.
  2. Wait 30 seconds.
  3. Plug the power cord directly back into a wall outlet. Check that the wall outlet is working correctly.
  4. Quickly tap and release the power button to turn the device back on.

Solution 3: Reboot the printer

  1. Unplug the power cable.
  2. Wait one minute.
  3. Plug the power cable back in.

Solution 4: Check for Error BA00

  1. Return to the Home screen of the device.
  2. Open the Print on Envelopes app.
  3. If the Print on Envelopes or Create Shipping Labels app has a BA00 error, first resolve BA00.
If you need further assistance, please contact us.

Related topics

UPDATED: April 11, 2022

Contact Us
Live Chat
Available • Closes at 8pm ET
Sales team hours are 8am-6pm ET
Live Chat
Live Chat is currently unavailable.
Chat is available Mon-Fri, 8am-8pm ET
Create a case
Submit support requests (Sign in required)