Resolve "Error There is an error in XML document" with SendSuite Live eBay eCommerce integration

How to resolve the error "Error There is an error in XML document" when using the SendSuite Live eBay eCommerce integration tool.
Products affected: SendSuite® Live

Issue

When using the SendSuite® Live eCommerce integration tool with eBay, the following error message is displayed:
 
Error There is an error in XML document (14, 35).
Error    at System.Xml.Serialization.XmlSerializer.Deserialize(XmlReader xmlReader, String encodingStyle, XmlDeserializationEvents events)
   at System.Xml.Serialization.XmlSerializer.Deserialize(TextReader textReader)
   at PB.Common.Serializable.LoadSettingsFromFullPath[T](String fullPathToSettingsFile)
   at PB.Common.Serializable.LoadSettings[T](String settingsFile)
   at PB.EcommerceIntegration.Ebay.EbaySettings.RetrieveSettings()
   at PB.EcommerceIntegration.Ebay.EbayUserToken.EbayUserToken_Load(Object sender, EventArgs e)"

Cause

Communication between eBay and SendSuite Live is failing due to one or both of the following:
  • The eBay security token has expired. (The eBay security token expires every 18 months.)
  • The eBay account password has changed.

Resolution

Follow these steps to update SendSuite Live with your new eBay information and update the security token:
  1. Right-click the eCommerce icon in the taskbar and select Settings.
  2. In the window that opens, go to File > Edit Plugin.
  3. On the Step 1 tab, verify that all services for integration are highlighted (LivetoEbay, EbaytoLive).
  4. On the Step 2 tab, select LivetoEbay from the menu.
  5. On the Step 3 tab, select Add user, then select Grant Access.
  • If the menu is blank, select the Grant Access button, which will open eBay in Internet Explorer. Sign in to eBay and accept the terms to grant the integration program access to your eBay account.
  1. Select your ID from the menu.
  2. Select Get Token.
  3. When it is complete, close the integration window.
  4. Right-click on the integration icon in the taskbar and select Run > Web services.
  5. To verify that it is working, hold your mouse over the integration icon. A percent complete message should appear.
If this does not resolve the issue, contact client support.

UPDATED: August 14, 2021