The SendPro C Lite, SendPro C, SendPro+ (2H00, 8H00) screen is frozen on the clock screen

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Products affected: SendPro® C Lite, SendPro® C, SendPro®+ (2H00, 8H00)

Issue

The SendPro C Lite, SendPro C, SendPro+ (2H00, 8H00) screen is frozen on the clock and is unresponsive.

Cause

There may be an issue with the tablet battery.

Resolution

Restart the device:
  1. Unplug the power cable. The screen should turn off after 10 seconds.
  2. Wait 2 minutes.
  3. Plug the power cord back in. Check the wall outlet is functioning correctly.
  4. Quickly tap and release the power button to turn the meter back on.
Leave the device plugged in and powered on for two hours. If after two hours the display still shows the clock screen, contact technical support using the Contact Us options below.

UPDATED: December 08, 2020