Resolving the flashing red power light on the SendPro Mailstation
If the power light on your SendPro Mailstation is flashing red, follow these steps to restart the device.
Products affected: SendPro® Mailstation
Issue
Flashing red power light
Cause
An internal error has occurred
Resolution
If you are installing your device for the first time, ensure the orange locking device has been removed from the printer carriage found inside the ink door.
Restart the device
- Hold the power button until the screen displays "Shutting Down."
- Once off wait 5 seconds.
- Tap the power button.
If the device does not shut down with the power button
- Disconnect the power cord from the back of the machine.
- Wait ten seconds.
- Plug the cord back in firmly.
- Tap the power button
If you need further assistance, please contact us.
UPDATED: March 11, 2022
Contact Us
Live Chat
Available • Closes at 8pm ET
Sales team hours are 8am-6pm ET
Sales team hours are 8am-6pm ET
Live Chat
Live Chat is currently unavailable.
Chat is available Mon-Fri, 8am-8pm ET
Chat is available Mon-Fri, 8am-8pm ET
Create a case
Submit support requests
(Sign in required)