"Error 27502. Could not connect to SQL Server" in SendSuite Tracking

Learn how to resolve the message "Error 27502. Could not connect to SQL Server" in SendSuite Tracking.
Products affected: SendSuite® Tracking

Issue

When installing or upgrading to SendSuite Tracking version 14.2 or higher, the message "Error 27502. Could not connect to SQL Server [server name]. A network-related or instance-specific error has occurred while establishing a connection to SQL Server. Server is not found or not accessible. Check if instance name is correct and if SQL Server is configure..." appears.

Cause

The SendSuite Tracking 14.2 release contained a change of the data connection provider from SQLOLEDB to SQL Native Client 11 (SQLNCLI11). If the server does not have the SQLNCLI11 driver installed, the error will appear when the installer attempts to connect to the SQL Server instance.

Resolution

  1. On the application server, download and install the SQL Native Client bundle from Microsoft.
  2. Restart the server, if required.
  3. Attempt the installation again.

Test Criteria

  1. Open the ODBC administrator:
    1. In the Windows Search field, type ODBC.
    2. Click on ODBC Data Sources. Choose 32-bit or 64-bit based on your operating system's architecture.
  2. In the ODBC Data Source Administrator window, click on the Drivers tab.
  3. Confirm that the SQL Server Native Client 11.0 is installed and that all of the values are as follows:
    • Name: SQL Server Native Client 11.0
    • Version: 2011.110.x.x. or greater
    • Company: Microsoft Corporation
    • File: SQLNCLI11.DLL
    • Date: 1/6/2018 or newer

    ODBC window_500x355

UPDATED: August 14, 2021