How to resolve an overfilled postage meter

Print this support article
Products affected: mailstation™, mailstation2™, DM100®i, DM125™, DM200L™ DM225™, DM300C™, DM400C™, DM450C™, DM475™, DM500™, DM525™, DM550™, DM575™, DM800™, DM800i™, DM825™, DM875™, DM900™, DM925™, DM1000™, DM1100™, DM Infinity™, Connect+® 500W, Connect+® 1000, Connect+® 2000, Connect+® 3000, SendPro™ P1000, SendPro™ P1500, SendPro™ P2000, SendPro™ P3000

Issue

You have refilled your meter for too much postage.

Cause

You chose an amount greater than intended, or the postage meter refilled more than once.

Resolution

If you have accidentally overfilled your postage meter, please use the Contact Us options below Monday through Friday, from 8 am to 8 pm Eastern Time. Please have your model number ready.

Note: Do not request a refund to reverse a meter refill.

UPDATED: September 05, 2019