Resolve UPS API labels print with wrong orientation or do not print in SendSuite Live

Learn how to resolve when UPS API labels print with the wrong orientation or do not print at all in SendSuite Live.
Products affected: SendSuite® Live

Issue

All labels print properly from SendSuite® Live except for UPS API labels, which print with the wrong orientation or do not print at all.

Cause

UPS API sends labels with landscape orientation, whereas all other carriers use portrait orientation.

Resolution

In order to resolve this issue, the label printer driver must be set to landscape. However, setting the printer to landscape will break the printing of all the other carrier labels. To avoid needing to switch back and forth between formats, a second label printer can be created for UPS API labels.
  1. Create a second label printer using the same driver and name the new printer UPSAPI. The steps will vary by printer model. Contact your IT department if needed.
  2. Set the printer orientation to landscape. The location of the orientation setting will vary by printer model. For a 1E26 printer, it is under the General tab > Preferences.
  3. Go to SendSuite Live Shipping Administration.
  4. Under Shipment Server Configuration > Devices > Printer Queues, create a Printer Queue. Name it UPS API.
  5. The Location will be the UNC path of the printer (for example, \\computername\UPSAPI). Contact your IT department to obtain this information if needed.
  6. Select the appropriate Printer Model. For a 1E26 printer, select 2844-Z.
  7. Go to Shipment Server Configuration > Outputs > Labels.
  8. Select UPS API and set the following settings:
  • Specific carrier: UPS API
  • Label Type: Label
  • Generate From: Carrier
  • Format: Zebra
  • Printer Type: Windows
  • Printer: The new printer you created
  • Stock: 4 x 6
When printing UPS API labels, select this printer. When printing all other labels, select your original printer.

If you need additional assistance, contact software support.

UPDATED: August 14, 2021