"Print services has stopped" message on the SendPro C Lite, SendPro C, SendPro+, SendPro C Auto

If your device is displaying the message "Print services has stopped," your device software may be out of date. Contact Pitney Bowes technical support for assistance.
Products affected: SendPro® C Lite, SendPro® C, SendPro®+, SendPro® C Auto (2H00, 8H00, 9H00)

Issue

When trying to print, the message "Print services has stopped" appears.

Cause

The device software may be out of date.

Resolution

This issue must be resolved by a Pitney Bowes representative. Please contact us.

UPDATED: March 18, 2022

Contact Us
Live Chat
Available • Closes at 8pm ET
Sales team hours are 8am-6pm ET
Live Chat
Live Chat is currently unavailable.
Chat is available Mon-Fri, 8am-8pm ET
Create a case
Submit support requests (Sign in required)
1-877-213-7284
Mon-Fri, 8am - 8pm ET