"Low Battery" or "Battery Urgent" message on the mailstation series

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Products affected: mailstation™, mailstation2™

Issue

Your meter displays the message "Low Battery" or "Battery Urgent".

Cause

Your meter's internal battery is nearing the end of its life.

Resolution

Solution 1: Clear your error message temporarily
  1. Press the Clear/Back button to clear the message and run mail temporarily
  2. Go to Solution 3 to request battery replacement service.

Solution 2: Restart your meter to clear your error message
  1. Unplug the power cord.
  2. Wait one full minute.
  3. Plug the power cord back in, ensuring that it is plugged directly into a wall outlet.
If your battery message returns after restarting, your meter needs to be replaced.

Solution 3: Request meter replacement service
  1.  If your battery message returns after restarting, your meter needs to be replaced. Create a case for technical support to request a replacement meter.

A replacement battery is required to ensure uninterrupted functionality. Your meter's settings and other information could be lost if your battery expires.

UPDATED: February 21, 2020