Date printed on mail is wrong on the SendPro C Lite, SendPro C, SendPro+, SendPro C Auto

Check the date advance setting if the date on your mail is printed wrong.
Products affected: SendPro® C Lite, SendPro® C, SendPro®+, SendPro® C Auto (2H00, 8H00, 9H00)

Issue

The date printed on the mail is wrong.

Cause

The auto date advance setting may be incorrect.

Resolution

If the date appearing on the meter is between 1-30 days in advance of today's date, check the auto date advance:
  1. Tap Print on Envelopes on the Home screen. 
  2. Tap the Date.
  3. Tap Today.
  4. If the correct date appears, tap Apply.
If you need further assistance, please contact us.

UPDATED: March 11, 2022