Resolve a frozen screen on the Connect+ series and SendPro P Series
Learn how to resolve a frozen screen on the Connect+ 500W, Connect+ 1000, Connect+ 2000, Connect+ 3000, SendPro P1000, SendPro P1500, SendPro P2000 and SendPro P3000.
Products affected: Connect+® 500W, Connect+® 1000, Connect+® 2000, Connect+® 3000, SendPro® P1000, SendPro® P1500, SendPro® P2000, SendPro® P3000
Issue
The touchscreen is not responding.
Cause
The touchscreen is not connected or is malfunctioning.
Resolution
Solution 1: Return to the Home screen
Press the Home button. The task you are performing may not be responding, but the meter may still be working.
Solution 2: Check the USB cable
- Locate the USB cable coming from the base of the monitor stand.
- Make make sure the USB cable is securely plugged into the USB port on the back of the machine.
If this does not work, go to the next solution.
Solution 3: Try another USB port
Plug the USB cable into another available port if one is available.
If this does not work, contact customer support.
Related topicsUPDATED: August 14, 2021
Contact Us
Live Chat
Available • Closes at 8pm ET
Sales team hours are 8am-6pm ET
Sales team hours are 8am-6pm ET
Live Chat
Live Chat is currently unavailable.
Chat is available Mon-Fri, 8am-8pm ET
Chat is available Mon-Fri, 8am-8pm ET
Create a case
Submit support requests
(Sign in required)