Resolve an ink leak on a Pitney Bowes postage meter
Learn how to resolve an ink leak on a Pitney Bowes postage meter.
Products affected: mailstation™, mailstation2™, DM100®i, DM125™, DM200L™ DM225™, DM300C™, DM400C™, DM450C™, DM475™, Connect+® 500W, Connect+® 1000, Connect+® 2000, Connect+® 3000, SendPro® P1000, SendPro® P1500, SendPro® P2000, SendPro® P3000, SendPro® 300
Issue
You have ink leaks, either inside or outside of the postage meter.
Cause
An internal component failed.
Resolution
Follow these steps to resolve your issue:
- Turn off the postage meter.
- Unplug the meter's power cord.
- Use the Contact Us options below to contact technical support. Have your model number and serial number ready.
UPDATED: August 14, 2021
Contact Us
Live Chat
Available • Closes at 8pm ET
Sales team hours are 8am-6pm ET
Sales team hours are 8am-6pm ET
Live Chat
Live Chat is currently unavailable.
Chat is available Mon-Fri, 8am-8pm ET
Chat is available Mon-Fri, 8am-8pm ET
Create a case
Submit support requests
(Sign in required)