"Set Payment Method" message in SendPro Online

If you see the message "Set Payment Method" in SendPro Online, that means that the postage payment method has not been set up.
Products affected: SendPro® Online

Issue

When signing in to SendPro Online, the message "Set Payment Method" appears.

Cause

The postage payment method has not been set up.

Resolution

To add a credit card as your postage payment method, click Add payment method on the message. If you already closed the message, click Setup Postage Payment Method in the upper right.

If you need to add a Pitney Bowes Reserve Account or Purchase Power Account instead of a credit card, please contact support.

If you need further assistance, please use the Contact Us options below.

UPDATED: May 10, 2021

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