"Set Payment Method" message in SendPro Online, PitneyShip, or PitneyShip Pro

The message "Set Payment Method" means that the postage payment method has not been set up.
Products affected: SendPro® Online, PitneyShip™, PitneyShip™ Pro

Issue

When signing in to SendPro Online, PitneyShip, or PitneyShip Pro, the message "Set Payment Method" appears.

Cause

The postage payment method has not been set up.

Resolution

To add a credit card as your postage payment method, click Add payment method on the message. If you already closed the message, click Setup Postage Payment Method in the upper right.

If you need to add a Pitney Bowes  or instead of a credit card, please contact us.

UPDATED: November 13, 2023