SendPro Online or PitneyShip scale screen is blank
If your SendPro Online or PitneyShip scale screen is blank, it most likely has no power.
Products affected: SendPro® Online, PitneyShip™
Issue
The screen on your scale is blank.
Cause
The scale has no power.
Resolution
Solution 1: Ensure that the USB cable is connected directly to the computer
Ensure that the USB cable is connected directly from the scale to the computer. Do not use a USB hub between the USB scale and the computer. If the scale is already plugged directly into the computer, try a different USB port on the computer.
If the issue is not resolved, try solution 2.
Solution 2: Replace the battery
If you are using the optional 9-volt battery in the scale, replace the battery. This does not apply when using a USB connection.
If you need further assistance, please contact us.
UPDATED: April 25, 2022
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