"An error has occurred" message when printing with DeviceHub in PitneyShip or PitneyShip Pro
Issue
When printing with DeviceHub in PitneyShip or PitneyShip Pro, the message "An error has occurred" appears.
Cause
The printer driver being used is not compatible with DeviceHub.
Resolution
- Solution 1: Make sure that DeviceHub is installed
- Solution 2: Verify that DeviceHub is running
- Solution 3: Make sure that your printer is connected and online
- Solution 4: Reconnect DeviceHub
- Solution 5: Uninstall and reinstall DeviceHub
- Solution 6: Update the print driver
- Solution 7: Check compatible envelope printers or print to PDF
To install DeviceHub, see the instructions for your product:
Solution 2: Verify that DeviceHub is runningThere should be a DeviceHub icon in the Windows system tray (small icons near the clock) or Mac OS menu bar to show that it is running.
If this icon is missing, find DeviceHub in your programs list and restart it.
Once the DeviceHub icon appears, hover your mouse over the icon to see the connection status and wait until it shows an Online status.
Solution 3: Make sure that your printer is connected and online- In PitneyShip or PitneyShip Pro, go to Settings > My Devices.
- Verify that your printer shows an Online or Idle status.
- If the status is Offline or Other, verify that the printer is on and is connected correctly to the computer.
- Find the DeviceHub icon in Windows system tray (small icons near the clock) or Mac OS menu bar.
- Right-click on the DeviceHub icon and choose Reconnect.
- Once the DeviceHub icon appears, hover your mouse over the icon to see the connection status and wait until it shows an Online status.
- Uninstall DeviceHub. See Uninstalling DeviceHub.
- Reinstall DeviceHub. See Installing DeviceHub.
Solution 6: Update the print driver
If using an HP printer, install the HP Universal Print Driver
- Go to HP's Universal Print Driver download page.
- Select the + symbol next to Driver-Universal Print Driver.
- Select the Download button for HP Universal Print Driver for Windows PostScript.
- Run the downloaded file.
- Select Unzip in the WinZip Self-Extractor wizard window.
- Select Yes to the License Agreement.
- Follow the prompts to complete the installation. Steps may vary based on your HP printer model and connection type.
If not using an HP printer, install the latest printer driver for your printer
If you are using a non-HP printer, go to your printer manufacturer's website and download and install the latest version of the printer driver for your printer.
Solution 7: Check compatible envelope printers or print to PDF
- If printing on envelopes, and the issue is not resolved, please refer to Compatible printers and scales for PitneyShip and PitneyShip Pro..
- If printing stamp sheets or shipping labels, choose Print to PDF instead of your printer in the Print Options window.
UPDATED: August 18, 2023