"You have not completed your account registration" message displays when signing in online

Instructions on resolving the error message "You have not completed your account registration" message when signing in online.

Issue 

The message "You have not completed your account registration" message displays when signing in to your online portal. 

Cause 

You have registered for a Your Account profile but have not clicked the link in the verification email sent by Pitney Bowes. 

Resolution

  1. Select the Resend email link. 
  2. Click the link in the verification email sent by us. 
  3. Sign in to your account.

UPDATED: January 26, 2024