Unable to delete a payment method from your online portal

The message "This credit card may not be deleted because it is currently being used as the AutoPay payment source for the account(s) listed below" displays when deleting autopay in your online account.

Issue 

The message "This credit card may not be deleted because it is currently being used as the AutoPay payment source for the account(s) listed below. To delete it, you must change the AutoPay payment source or delete the automatic payment for the account(s) first." appears when deleting autopay in your online account. 

Cause 

Your credit card can not be deleted as it is currently assigned as the payment method for one or more accounts. 

Resolution 

Solution 1: Update the credit card linked to your AutoPay

  1. Select the Manage AutoPay link in the error message. 
  2. Update your existing AutoPay payment method. 
  3. Click Save Settings
  4. Return to your payment methods to delete the old credit card. 

Solution 2: Stop AutoPay on the account.

  1. Select the Manage AutoPay link in the error message. 
  2. Click Stop AutoPay at the bottom of the form. 
  3. Select Stop AutoPay
  4. Return to your payment methods to delete the old credit card.

UPDATED: February 06, 2024