“[Errno 10013] error while attempting to bind on address ('127.0.0.1', 443):..." message when activating DeviceHub in PitneyShip, PitneyShip Pro, or PitneyShip Enterprise
The message “[Errno 10013] error while attempting to bind on address ('127.0.0.1', 443): an attempt was made to access a socket in a way forbidden by its access permissions" happens because port 443 is not free.
Products affected: PitneyShip®, PitneyShip® Pro, PitneyShip® Enterprise
Issue
When activating DeviceHub, the logs show the message “[Errno 10013] error while attempting to bind on address ('127.0.0.1', 443): an attempt was made to access a socket in a way forbidden by its access permissions”
Cause
Port 443 is not free.
Resolution
Note: These steps may need to be completed by your IT department or network administrator.
- From the system tray, close DeviceHub
- Open DOS Command Window and run this command: netstat -ano -p tcp
- Search for 127.0.0.1:443 or 0.0.0.0:443 and note the PID Number.
Or
Steps in Task Manager
- Open Task Manager and select the Details tab.
- Search for the PID. Stop the program and try again to re-launch DeviceHub. Some programs maybe running via a Windows Service and will require the stopping of the service, so the program does not restart.
- Launch DeviceHub.
- In PitneyShip, PitneyShip Pro, or PitneyShip Enterprise go to My Devices and click to Activate. You may need to refresh the page.
If you are still receiving this error code follow these steps for additional troubleshooting:
- Find the application that is using port 443.
- Shut down the application using port 443.
- Start DeviceHub.
- Activate DeviceHub.
- Shutdown DeviceHub.
- Restart the original conflicting application.
- Start DeviceHub.
If you need further assistance, please chat with us.
UPDATED: April 21, 2025