"Something went wrong" message while printing UPS shipping labels on the SendPro C Lite, SendPro C, SendPro+, SendPro C Auto
Try printing the UPS label from a computer or sign out then sign into Create Shipping Labels if the message "Something went wrong UPS code" appears.
Products affected: SendPro® C Lite, SendPro® C, SendPro®+, SendPro® C Auto (8H00, 9H00)
Issue
The message Something went wrong appears when trying to activate or print UPS shipping labels.
Cause
We have made a change to UPS accounts. You need to activate PB-UPS Rates within PitneyShip. You also need to set up a credit card payment method to pay for your UPS shipping labels.
Resolution
Activating the carrier
- Log into PitneyShip on your computer.
- Select Settings > Carriers.
- Select the Activate button next to UPS.
- Select I agree to UPS terms and conditions.
- Select Activate Now.
- Select Close. The account will be added with the Display Name of PB-UPS Rates.
Adding a payment method
If you have a Pitney Bowes UPS Rate Account, you can select a payment method for labels created with that account. Note: UPS labels that are created with a non-Pitney Bowes UPS Rate Account will be billed to you by the carrier as usual.
- Select Settings > Payment Methods.
- Select the Usage Preferences tab or the Manage Usage Preferences link.
- From the PB-UPS Rates Account Labels menu, select the payment method you wish to use for UPS labels that are created with your Pitney Bowes UPS Rate Account.
- Select Save.
UPDATED: June 26, 2025