"Failed To Add Postage - PS-1000 Temporary error processing payment" message in PitneyShip or ShipAccel
If you see tthe message "Failed To Add Postage [PS-1000] Temporary error processing payment. Try again later.", there may be a problem with the credit card on file, or an issue that requires the card to be removed and re-added.
Products affected: PitneyShip®, ShipAccel
Issue
When trying to add postage funds, the message "Failed To Add Postage [PS-1000] Temporary error processing payment. Try again later." appears.
Cause
There may be a problem with the credit card on file, or an issue that requires the card to be removed and re-added.
Resolution
Try re-adding the credit card:
- Select Settings > Payment Methods.
- Select Add Credit Card.
- Enter the credit card information and click Submit.
- Select the Usage Preferences tab or the Manage Usage Preferences link.
- Under USPS Postage Account Balance, select the new card from the first menu to set it as the primary payment method. Set any other primary payment methods if needed.
- Go back to the Wallet tab.
- Expand the old card entry.
- Select Remove.
- Select Delete to confirm.
- Try adding postage funds again.
If you still experience the same error, try adding a different credit card as the primary payment method.
UPDATED: July 08, 2025