"Failed To Add Postage - PS-1000 Temporary error processing payment" message in PitneyShip or ShipAccel

If you see tthe message "Failed To Add Postage [PS-1000] Temporary error processing payment. Try again later.", there may be a problem with the credit card on file, or an issue that requires the card to be removed and re-added.

Products affected: PitneyShip®, ShipAccel

Issue

When trying to add postage funds, the message "Failed To Add Postage [PS-1000] Temporary error processing payment. Try again later." appears.

Cause

There may be a problem with the credit card on file, or an issue that requires the card to be removed and re-added.

Resolution

Try re-adding the credit card:

  1. Select Settings > Payment Methods.
  2. Select Add Credit Card.
  3. Enter the credit card information and click Submit.
  4. Select the Usage Preferences tab or the Manage Usage Preferences link.
  5. Under USPS Postage Account Balance, select the new card from the first menu to set it as the primary payment method. Set any other primary payment methods if needed.
  6. Go back to the Wallet tab.
  7. Expand the old card entry.
  8. Select Remove.
  9. Select Delete to confirm.
  10. Try adding postage funds again.

If you still experience the same error, try adding a different credit card as the primary payment method.

UPDATED: July 08, 2025