Frozen screen on the SendPro P Series

Learn how to resolve a frozen screen on the SendPro P1000, SendPro P1500, SendPro P2000 and SendPro P3000.

Products affected: SendPro® P1000, SendPro® P1500, SendPro® P2000, SendPro® P3000

Issue

The touchscreen is not responding.

Cause

The touchscreen is not connected or is malfunctioning.

Resolution

Solution 1 

Press the Home button. The task you are performing may not be responding, but the franking machine may still be working.

Solution 2 

Remove then replace the USB cable between the franking machine and the display.

If the touchscreen is still not functioning, you can connect a USB mouse to the franking machine and use that until the touchscreen can be replaced.

Related Topics

UPDATED: 16 June 2025