"Global.paymentmethod.unknown: xxxxxxxxxxxx" message in PitneyShip Pro and PitneyShip Enterprise

Learn how to resolve the message "Global.paymentmethod.unknown: xxxxxxxxxxxx" in PitneyShip Pro or PitneyShip Enterprise.

Products affected: SendPro® Online powered by PitneyShip® Pro and PitneyShip® Enterprise

Issue

When attempting to add postage in PitneyShip Pro or PitneyShip Enterprise, the error message "Global.paymentmethod.unknown: xxxxxxxxxxxx" is displayed.

Cause

An issue occurred with the Pitney Bowes systems for setup of your Payment Method for PitneyShip Pro or PitneyShip Enterprise. This is not a problem with your computer, web browser, or PitneyShip Pro or PitneyShip Enterprise account.

Resolution

If you experience this error, please contact client support.

UPDATED: 25 July 2025