"You have not completed your account registration" message in PitneyShip Pro and PitneyShip Enterprise

The message "You have not completed your account registration" means that the username is inactive because the account still needs to be activated.

Products affected: SendPro® Online powered by PitneyShip® Pro and PitneyShip® Enterprise

Issue

When attempting to sign in to PitneyShip Pro or PitneyShip Enterprise, the message "You have not completed your account registration" is displayed.

Cause

The username being used has been created, but is currently inactive.

Resolution

In the message, there is a "Resend email" option. Select Resend email to resend the registration/activation message to the email address being used for the SendPro account. Follow the prompts in that message to activate the PitneyShip Pro or PitneyShip Enterprise account.

UPDATED: 24 July 2025