"The password you provided was not recognized. Please try again." in PitneyShip Pro and PitneyShip Enterprise
Learn how to resolve the error “The password you provided was not recognised. Please try again.” in PitneyShip Pro and PitneyShip Enterprise.
Products affected: Connect+® 500W, Connect+® 1000, Connect+® 2000, Connect+® 3000, SendPro® P1000, SendPro® P1500, SendPro® P2000, SendPro® P3000, SendPro® Online powered by PitneyShip® Pro and PitneyShip® Enterprise
Issue
When attempting to sign in to PitneyShip Pro or PitneyShip Enterprise, the message "The password you provided was not recognised. Please try again." is displayed.
Cause
The password being used is not a valid password for PitneyShip Pro or PitneyShip Enterprise.
Resolution
If you receive this error, reset your PitneyShip Pro or PitneyShip Enterprise password. If you continue to receive the same error after resetting your password, please contact client support.
UPDATED: 24 July 2025