Blank or white screen in PitneyShip Pro software for Windows or Mac

Learn how to resolve a white or blank screen in SendPro for Windows or Mac.
Products affected: SendPro® Online powered by PitneyShip® Pro

Issue

When attempting to use PitneyShip Pro software on a computer, a blank or white page is displayed.

Cause

  • There may be an issue with your Internet connection.
  • A firewall, anti-virus program, or proxy server on your network may be blocking the connection.

Resolution

To resolve this issue:
  1. Attempt to access any other website, such as www.google.com. If you also get a blank page at any other website, then there is most likely a problem with your internet connection. Contact your IT department or Internet Service Provider (ISP) for assistance.
  2. If you do not get a blank page at any other website, but you continue to get a blank page in PitneyShip Pro, then a firewall, anti-virus program, or proxy server on your network is most likely blocking your connection to the SendPro servers. To resolve this issue, you will need to whitelist or add an exception for the following addresses to ensure that traffic to and from them is allowed. Contact your IT department for assistance.
  • https://sendpro.pitneybowes.com
  • http://www.pitneybowes.com
  • http://www.pb.com
  • https://login.pitneybowes.com/sendpro
  • https://sending.us.pitneybowes.com/
  • imp.sl.pb.com
  • agent.sl.pb.com
  • 199.231.33.6
  • 199.231.44.12
If you continue to get a blank page after whitelisting all of these addresses in your firewall, anti-virus program, and any network proxy servers, contact Pitney Bowes client support.

UPDATED: 05 October 2023