"Duplicate Personnel ID" message when importing users in PitneyShip Pro, PitneyShip Enterprise, PitneyTrack Asset, PitneyTrack Inbound, PitneyTrack Enterprise and PitneyLockers
Products affected: SendPro® Online powered by PitneyShip® Pro, PitneyShip® Enterprise, PitneyTrack® Asset, PitneyTrack® Inbound, PitneyTrack® Enterprise, PitneyLockers
Issue
When importing contacts, the message "Duplicate Personnel ID" occurs.
Cause
The PersonnelID values in the CSV import file are not unique.
Resolution
Check the CSV file (all users)
Ensure that the values in the PersonnelID column in your CSV import file are either unique for each user, or blank for all users, then reimport the file.
PitneyTrack Inbound (Receiving) users only
The resolution depends upon whether or not you use the ID Card Scan feature when delivering packages. This feature requires unique Personnel IDs for all contacts. Personnel IDs are unique identifiers like employee or student ID numbers that are encoded on the ID cards of those individuals.
If Personnel IDs are required in the Address Book, then the ID Card Scan option is available for proof of delivery while delivering packages. If Personnel IDs are not required in the Address Book, then the ID Card Scan option is not available for proof of delivery.
If you scan ID cards for deliveries
- Select Settings > Delivery..
- Set ID Card Scan to Required or Optional as needed for both Web Browser and Mobile App.
- Select the Update Settings button at the top.
- Go to Settings > Address Book.
- Select the Contact Settings tab.
- Click the slider next to Require Personnel ID for internal deliveries to turn it on.
- Refresh your browser to apply these changes.
- In your CSV import file, ensure that the values in the PersonnelID column are unique for each user, then re-import the file.
If you do not scan ID cards for deliveries
- Select Settings > Delivery.
- Set ID Card Scan to Off for both Web Browser and Mobile App.
- Select the Update Settings button at the top.
- Go to Settings > Address Book.
- Select the Contact Settings tab.
- Click the slider next to Require Personnel ID for internal deliveries to turn it off.
- In your CSV import file, remove the values from the PersonnelID column and re-import the file.
The features and options you see may vary depending upon your role and subscription. If you have any questions regarding your permissions, please contact your administrator.
UPDATED: 05 June 2026