"Please enter a valid Invoice Number" message displays when registering for Your Account
Learn how to resolve the message "Please enter a valid Invoice number" when registering for Your Account.
Issue
The message "Please Enter a valid Invoice Number" appears when registering for Your Account
Cause
The invoice number you are using to register is not recognised.
Resolution
- Confirm the country flag in the top right corner is the same location as the account address.
- Verify the invoice number is correct.
If you need further assistance, please chat with us.
UPDATED: 28 August 2024