Unable to print errors when sending to Northern Ireland in PitneyShip Pro
Products affected: PitneyShip® Pro
Issue
One of the following error messages shows when trying to send to Northern Ireland from other parts of the UK.
- Recipient UKIMS reference is required.
- UKIMS reference must contain a matching EORI reference.
- Sorry, this is not you. It is us or Royal Mail. Please retry.
- Service in not available for this delivery postcode area.
Cause
Information required to comply with the Windsor framework for sending to Northern Ireland is missing or there is a Royal Mail issue.
Resolution
See the relevant error message resolution below for actions.
Recipient UKIMS reference is required
Return to Additional Customs Information and enter a recipient UKIMS reference number.
UKIMS reference must contain a matching EORI reference
The UKIMS reference number entered does not match the corresponding EORI number for sender or recipient.
Return to Additional Customs Information and enter or re-enter the correct corresponding UKIMS number.
Sorry, this is not you. It is us or Royal Mail. Please retry
Retry printing your label.
If the problem persists, check:
- Your internet connection is working
- You are logged into your account
- Any printers are connected and visible
- All of the information is entered correctly in the print labels screen
If you are still unable to print your label visit Errors and other problems via support on your system or the Pitney Bowes Support site or Royal Mail support on their website for further assistance.
Service in not available for this delivery postcode area
Return to the print labels screen and select an alternative service option.
UPDATED: 23 May 2025