Postage Failed error on the in PitneyShip Pro
Learn how to resolve Postage Failed error on the PitneyShip Pro.
Products affected: SendPro® Online powered by PitneyShip® Pro
Issue
"Postage Failed" error appears when trying to print labels on PitneyShip Pro. Your postage could not be processed and "Create Postage and try again" is encountered.
Cause
There May be insufficient funds for the type of postage needed.
If sufficient funds are available, There may be an underlying issue with your account.
Resolution
Resolution 1: Add Funds
- Check that there are sufficient funds available for the job to be printed in your account balance at the top right of the screen.
- If funds are low, see Refilling Postage.
Resolution 2: Check DeviceHub is running
- Check if DeviceHub is running, activated and test the system operation by selecting a zero print and adding to a sheet.
- If the Zero test works, but the stamp required does not print and results in the error re-occurring please contact support.
Related topics:
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UPDATED: 22 December 2025