"No payment method found" error on the SendPro Mailstation

If your device displays "No payment method found" when you try to refill postage, change your USPS payment method in SendPro Online or PitneyShip.
Products affected: SendPro® Mailstation, SendPro® Mailstation LITE (HZ0L)

Issue

The device displays "No payment method found" when you try to refill postage.

Cause

Your device is not linked to a funding method.

Resolution

Follow these steps to add a payment method:

  1. Log in to PitneyShip using the same email and password that you used to install the SendPro MailStation.
  2. When you sign in to PitneyShip, the message "Set Payment Method" appears.
  3. Choose a payment method:
    • To add a credit card as your postage payment method:
      • Click Add payment method on the message, or
      • If you already closed the message, click Setup Postage Payment Method in the upper right.
    • To add a Pitney Bowes Reserve Account or Purchase Power Account, contact Pitney Bowes support.

Related topics

If you need further assistance, please chat with us.

UPDATED: October 13, 2023