"DEVICE HUB Connection error" message when printing in PitneyShip or PitneyShip Pro

The message "DEVICE HUB Connection error" may occur when printing if the printer is configured to "Print directly to the printer" instead of spooling.
Products affected: PitneyShip™, PitneyShip™ Pro

Issue

When printing, the message "DEVICE HUB Connection error" appears. The message may also say "There was a problem with your stamp" or "The stamp was generated but unable to print".

Cause

The printer is configured to "Print directly to the printer" instead of spooling.

Resolution

  1. Press the Windows + r on your keyboard to open the Run command.
  2. Type Control Panel and click OK.
  3. Change the View by menu to Small icons.
  4. Select Devices and Printers.
  5. Right-click on your printer and select Printer properties.
  6. Select the Advanced tab.
  7. Select Spool print documents so program finishes printing faster.
    Windows print spool setting
  8. Click OK.
  9. Try the printing the transaction again by clicking Try Again on the error message.
    "DEVICE HUB Connection error" Try Again button

If you need further assistance, please contact us.

UPDATED: August 08, 2022

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