"We could not process your payment" message in PitneyShip Pro
Learn how to resolve the message "We could not process your payment" in PitneyShip Pro.
Products affected: Connect+® 500W, Connect+® 1000, Connect+® 2000, Connect+® 3000, SendPro® P1000, SendPro® P1500, SendPro® P2000, SendPro® P3000, SendPro® Online powered by PitneyShip® Pro
Issue
When attempting to add postage in PitneyShip Pro, the message "We could not process your payment" is displayed.
Cause
This indicates that there are not enough funds available in your PrePay or Pay As You Go account.
Resolution
If the balance in your PrePay or Pay As You Go account is less than the amount you are attempting to add in PitneyShip Pro, add funds to your account by paying any outstanding invoices.
Check for outstanding invoices on Your Account.
Find out how to pay by bank transfer or Direct Debit.
UPDATED: 01 August 2025