"errorCode": "PB-APIM-ERR-1004", "errorDescription": "Invalid API Call" when registering PB Shipping API in SendSuite Live

Learn how to resolve the error "errorCode": "PB-APIM-ERR-1004", "errorDescription": "Invalid API Call" when attempting to register the PB Shipping API carrier in SendSuite Live.
Products affected: SendSuite® Live

Issue

When setting up the PB Shipping API carrier in SendSuite® Live, it does not register and displays the error:
"errorCode": "PB-APIM-ERR-1004",
"errorDescription": "Invalid API Call"

Cause

The ClientID is missing.

Resolution

Shipping API keys must be requested with the ClientID in the account number field.

UPDATED: August 14, 2021

Contact Us
Live Chat
Available • Closes at 8pm ET
Sales team hours are 8am-6pm ET
Live Chat
Live Chat is currently unavailable.
Chat is available Mon-Fri, 8am-8pm ET
Create a case
Submit support requests (Sign in required)