"Check Label Stock" when loading label stock in J696 printer used with SendSuite Live

Learn how to resolve the error "Check Label Stock" when loading label stock in a J696 printer used with SendSuite Live.
Products affected: SendSuiteĀ® Live

Issue

When loading label stock, the error "Check Label Stock" is displayed.

Cause

Label stock is loaded incorrectly, or the printer needs to be calibrated.

Resolution

  1. Ensure that the J696 is loaded correctly. There are diagrams within the J696 itself that describe how to load it. Also see the which has detailed instructions as to how to load the label stock.
  2. The internal sensor that the labels run through may also need to be physically adjusted by either pushing it further into the printer or pulling it out.
  3. If the issue is not resolved, try calibrating the J696:
    1. Press and hold the Feed (middle) button on the J696 for 3 seconds. Several labels should come out of the J696. Once complete, it should display a Ready status.
  4. Perform a test print.
  5. If the "Check Label Stock" message persists, repeat the above.
  6. If the "Check Label Stock" message still persists, contact Pitney Bowes software support.

UPDATED: August 14, 2021